Issue :
Column name already belongs to this DataTable
Cause:
The CRM View configured to be scheduled may probably have duplicate attributes in the FetchXml Query.
In case you find any duplicate values, this may indicate a Microsoft product issue.
Identify:
Open Advanced Find and select the Entity and View on which the issue occurs and click the ‘Download FetchXML’ button. (refer screenshot below)
Open the downloaded file in a text editor and check for if the fetchxml contains duplicate attributes.
In the sample below, the there are 2 instances of address1_city.
Resolution:
In case of the above a simple workaround would be remove the erroneous column from the view (from within CRM customizations)
If you still need the field on the view, you may need to create a new field and have the new field populated with the value from the old field (this may require development efforts)
Alternatively, one can raise a ticket with Microsoft to identify the cause of the duplicate attribute in FetchXML